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 EAGLE CADSOFT PROFESSIONAL   
 

                                               

EAGLE (Easily Applicable Graphical Layout Editor) is a schematic capture and PCB layout tool for hobbyists and DIY 
enthusiasts.  EAGLE is a popular choice as it is an easy to use, powerful and affordable schematic capture and printed 

circuit board design package. Here you will learn how to get started, how to use the interface, and how to design a board 

file from a schematic and export it for hardware use.  

GETTING STARTED   

OPENING  

Begin by opening EAGLE CADSOFT PRO. Click Start>Programs>EAGLE Layout Editor 4.16r2>EAGLE 4.16r2, or click on the 

shortcut on the desktop.  

You will see the EAGLE control panel.  

  

Now we need to create a Project which will contain the Schematic and the Board File.  For 

this click on File>New>Project  
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Rename the Project to the desired name.  

  

Now right click on the Project, select New>Schematic.  
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You will be able to see the Schematic window which is used to draw the desired circuit.    

  
Let us also look at the various Toolbar Buttons available in the Schematic editor as well as the Layout editor.  
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Tool  Usage  Tool  Usage  

        

Info  Provides information when clicked on 

something  

Net  Used to draw wire connections 

between component pins  

Display  Used to show/hide various details in 

schematic and Layout  

Wire  Same as above  

Add  Displays the component library  Junction  Used to place junctions in wire 

connections  

Gateswap  Used to change pin sequence in ICs  Route  Used for manual routing of tracks  

Name  Used to change name of the component      

Value  Used to mark the value of the component  Ripup  Used to break established track 

connections  

Miter  Used to change perpendicular lines to 

smooth edges  

Via  Used to place Via points  

Split  Used to change net shapes  Auto  Autorouter feature  

Invoke  Reveals Power Ports for select ICs  DRC  Used to Load and check design rules  

Text  Used to insert text  Errors  Displays errors if any  

        

  

CREATING THE SCHEMATIC   

In this discussion, we will be creating the following circuit. It is a common LED sequencer circuit which lights up a series 

of 10 LEDs sequentially.   

  

Source: http://www.allaboutcircuits.com/vol_6/chpt_7/6.html  

Now in the schematic window click on the ADD button in the toolbar, a window pops up. In that use the search bar to 
choose the component that is required. Almost all the components in the market are available in this library but the 
names of devices have to be specific or else a result may not appear. Click on the OK button once the component has 
been chosen.   

http://www.allaboutcircuits.com/vol_6/chpt_7/6.html
http://www.allaboutcircuits.com/vol_6/chpt_7/6.html
http://www.allaboutcircuits.com/vol_6/chpt_7/6.html
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CHOOSING A 555 TIMER  

For example to get a 555 timer, type “timer” in the search bar and you will get multiple results for the IC. Choose 

LM555N if your IC is a dual in-line package (the most common ones) or if it’s a surface mount device, choose LM555D.   

DIL08 stands for Dual In-Line 8 pin IC, likewise SO08 for Small Outline 8 pin IC (SOIC : Small Outline ICs)  
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Now drag the component onto the workspace and place it in the white area.   

 

  
A few components like the 4017N decade counter may not show its Power pins (VCC and GND). For such ICs we have to 

reveal those connections. To do this click on Edit>Invoke.  

  

Click on the space inside the IC, the Invoke window will pop up. Select the field inside and click OK.  
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Now the Power pins will be displayed, place it in any convenient location near the IC. All connections to VCC and GND of 

this IC should be given to these two pins.   

  
Now in this way add the rest of the components required in the LED Sequencer circuit using the ADD Component Library.  

  

Now we need to connect the components using wires or “nets”. For this select the Net tool from the Toolbar. Now click 
on one component pin and stretch the wire to the other component pin and click again to fix the wire between the two 

pins.   
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After all the wires connections are established, the schematic should look like this. Neat perpendicular connects always 

makes sure that there is no confusion in the wiring or any accidental connections.   

  

NOTE:  

1. Care should be taken while connecting the wires to the components. You should connect the wire exactly to the edge 

of the terminal as shown below:  

 Correct                                        Incorrect   

  

2. If you come across any junction you need to indicate the same using Junction  button.  

3. Make orthogonal connections that de-clutter the schematic and make it look organized.  

4. After giving connections ensure that all required wiring is established. This can be checked by selecting the Move tool 

and by clicking and dragging the symbol to see if the pins/leads are connected to the wires.  

With the above precautions connect the components.  
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This table will provide you the guideline to add some common components:  

#  COMPONENT  KEYWORD  GUIDELINE  DESCRIPTION  

1.  Berg 

strip/Connector/Push 

or Pull Switch  

connector  Scroll down to 

MTA02-100   

  

‘MTA’ signifies type of connector, ‘02’ signifies 

number of pins in the connector and ‘100’ 

signifies the size of the connector.  

If you want 3 pin select MTA03-100.  

2.  Resistor  resistor  Expand R-EU_ and 

select R- 

EU_0207/10.  

‘EU’ indicates European style resistors ‘0207’ 

signifies resistor type 10 signifies grid length. If 

you want Vertical mounting style select 

REU_0207/5V or R-EU_0207/2V. ‘V’ indicates 

vertical mounting type resistor  

3.  Capacitor  capacitor  Expand C , select  

C2.5/5  

‘2.5’ signifies the area and ‘5’ signifies the grid 

length  

4.  Diode  diode  Select 1N4004  You can use the same for 1N4007 also  

5.  Bridge rectifier  rectifier  Scroll down to RB1A 

and press OK  

  

6.  LED  led  Scroll down and 

expand LED.  

Select LED5MM  

5MM LED is the usual LED available in market.  

7.  Potential  

Divider/Trimm Pot  

trimm  Expand R-TRIMM 

and select R- 

TRIMM64W  

  

8.  OP-AMP  op amp  Expand *741 and 

select LM741P  

  

9.  PIC Microcontroller  

18F4550 (40 pin)  

microchip  Scroll down and 

expand  

PIC18F4*_20 and 

select  

PIC18F4550_40  

‘40’ signifies 40 Pin IC  

10.  PIC Microcontroller  

18F2550 (28 pin)  

microchip  Scroll down and 

expand  

PIC18F2*_28 and 

select  

PIC18F2550_28DIP  

‘28’ signifies 28 Pin IC and ‘DIP’ is abbreviation 

for Dual In Package  

NOTE: If you cannot find the required component you can create your own library file of the component which will be 

discussed later.  
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CREATING THE LAYOUT  

After all the connections are given, we create the “board” file. This is done by selecting the “create board file” tool in the 

upper toolbar. An info box appears, Click YES to proceed.   

  

This is the Layout window. The components and the workspace frame are shown. These components have to be 

optimally arranged inside the workspace frame which will be the actual placement of the devices in hardware.   

  

Drag and drop the components onto the workspace frame as shown below.  
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Now we need to load the standard DRC settings file which will determine various factors of the wires such as  

• Track thickness  

• Track spacing  

  Track 

routing  

Click on the DRC tool and the Load button in the DRC window. Load the DRC file (provided in the CD) and click open.  

Click on the Check button and ignore errors if any.   

  

  

In the next step, we need to lay the tracks or otherwise “route” it. To do this, select the Autoroute tool from the toolbar. 

Select the “|” option in both top and bottom fields since this is a double sided PCB. (For a single sided PCB select N/A in 

the top field and set only the bottom field). Press OK when done.  
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After autoroute completes, the board file will look like this. The blue lines represent the bottom side tracks and the red 

lines are the top side tracks. The autorouting is a programmed feature in EAGLE which optimally selects the best path for 

a track (though sometimes the tracks may unnecessarily be elongated) using search optimization algorithms.   
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EXPORTING THE IMAGE  

  

From this board file we can export images of the top side and bottom side separately for taking print. This can be done as 

follows.   

Select the display tool and in the display window select the labels called “bottom”, “pads” and “vias” and click OK.   

 
The board file now looks like this. To create an image of this bottom side track pattern click on File>Export>Image. In the 

Export Image dialog box   

• set resolution to 150 dpi  

• check monochrome  

• Provide a file name (“bottom”) and press OK.  
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Repeat the same for the Top side by deselecting “bottom” in the Display tool and selecting Top in its place. The exported 

top and bottom side images should look like this.   

 

Use an image editor such as MS Paint to invert the colors and to flip the top side image laterally.   

               
Take a printout of these two images in separate papers to get the final board file images for the two sides of the PCB. 

With the images we can proceed to the actual process of PCB fabrication.   

Thus we have demonstrated the design of circuits using the EAGLE Schematic editor and the creation of board file images 

using the Layout editor which is used in the fabrication of printed circuit boards.   

              

A finished single sided PCB that is ready to be used!  
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CREATING A CUSTOM LIBRARY FILE  
  

In this section, we will show you how to create a user defined component that can be used in the EAGLE schematic and 

layout editor. The need to create a user defined component is due to absence of certain rare components in the 

otherwise extensive parts library of EAGLE CAD.   

Begin by selecting File>New>Library.  
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You will notice 3 important buttons:  

1. Device  

2. Package  

3. Symbol  

These define the library file; the Package is the diagram that appears in the Board layout editor and the Symbol is the 

diagram that appears in the schematic editor. These two combined together forms the “Device”.   

  
Begin by clicking on Symbol. A pop up window will appear where the name of the device has to be provided. In this 

tutorial we will  be creating a 4 pin Transistor IC. Hence name the device as “TRANSISTOR”.  
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Click Yes in the Warning dialog box. The Symbol editor window now appears. Here we will be drawing the image of a 

standard NPN transistor.  

Use the Wire tool to draw the diagram as shown. For 45 degree lines select the angle button in the upper toolbar.   

  

The completed image should look like this:   

  
Now we need to add “Pins” to the diagram and for this select the Pin tool and add like this:  
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Additionally we can name the pins by selecting the “Names” tool and naming each pin separately.   

  

  

  
Once this has been completed select the Package button to create the package for the Transistor.  
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Click OK when this dialog appears:  

  

  

  
We begin by fixing the pads for the component. This is the most important part of creating a Library file as the 

dimensions of the custom drawing should match exactly with the specifications provided in the component’s datasheet. 

For example let’s consider a 28 pin PIC18F2550 Plastic Dual In-Line Package (PDIP) IC.   
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Note the values of Pitch ‘p’ and the IC width ‘E1’. These values would be the same for our 4 Pin Transistor IC, hence we 

can borrow them.  

 

  

Use the grid to create these dimensions so that the pads can be placed precisely. By default the grid is at 0.1 inches or 

2.54mm. We can change this to any value that is convenient.   

  

  
  

Now use the Pad tool to place 4 pads as shown.  
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Next would be to draw the package outline. Set grid to 0.025 inch as shown.  

  
While placing the pads care should be taken to place it in the proper sequence.  In this case the pads should be placed in 

anti-clockwise direction starting from the left bottom.  
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Use the Wire tool to draw the package outline. Leave a gap in the left which will be filled up with an arc that represents 

the “Notch” of the IC.  

  

Drawing the Notch using the Arc tool:  

  
At this stage we have created both the symbol and the package diagrams using the respective editors. Now the two files 

have to be merged in what is known as the Device editor. Click on the button and name the Device as “TRANSISTOR”.   
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Add the transistor symbol using the Add tool as shown.   

  

Place Symbol in the given space.   

  
Next click on New and add the transistor package:  
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The IC package diagram appears as shown. Click on Connect button to link the pins of the symbol with the pads of the 

package. This step completes the Device creation.  

Now the package has 4 pins whereas the transistor has only 3 leads viz. Base, Collector and Emitter. So 3 pins can be 

connected and the last pin can be left unconnected.  

We connect the pins in the following way:  

PAD 1  BASE  

PAD 2  N/C  

PAD 3  EMITTER  

PAD 4  COLLECTOR  

  

 

  
Now save the file at any preferred location in your hard drive. Before using this new library file in the schematic editor, 

the following actions are to be performed:  
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In the schematic editor,  

1. Click on Library  

2. Select Use: A window appears where the library file has to be located from hard drive and selected.  

3. Select “Update All” which will add the new library file to Eagle’s library database.   

  

  

  

The new user defined component is now ready to be used in the schematic editor!   

  

This completes the basic introductory tutorial of Eagle CAD and the rest of the finer details are left for the users’ 

exploration!       

  

HAPPY PCB MAKING    


