Arduino Uno as an ISP programmer

Programming a Target AVR using Arduino Uno board loaded with
ArduinolSP

(April 21, 2015, author: B. Lazar)

Arduino Uno + ArduinolSP form an ordinary ISP programmer that is used by avrdude to
program various 8 bit AVRs with any kind of hex file.
No bootloader is needed, no hardware removal from Arduino Uno is necessary

It may happen that you have an Arduino Uno that you bought, played a bit with it and now you want to
move further, to build your own board, which can be just a simple AVR microcontroller + an oscillator + a
LED, but you do not have an ISP programmer.

In reality, Arduino Uno is everything you need to program a large variety of AVRs. You just have to follow
the four steps described below:

1) Open Arduino 1.0.1 and upload ArduinolSP to Arduino Uno.

2) Connect the ISP pins of Arduino Uno to the Target AVR as indicated in the Fig.1.

3) Write your source code, compile it and generate the hex file.

4) Use avrdude command lines to upload the hex file into the Target AVR.

ISP ARDUINO UNO AS AN ISP PROGRAMMER

CONNECTIONS
LUNO. Arduino Uno R3 -> Target AVR Atmega328p

SS (Pin 10) -> RESET (Pin1)
MISO (Pin 11) -> MISO (Pin17)
MOSI (Pin 12) -> MOSI (Pin18)
SCK (Pin 13) -> SCK (Pin19)
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Each of the four steps explained in detail:

(1) Open Arduino 1.0.1 and upload ArduinolSP to Arduino Uno

Start Arduino 1.0.1, go to Files->Examples and open ArduinolSP. Then from Tools->Board select
Arduino Uno, from Tools->Programmer select AVR ISP or Arduino as ISP. Access Tools->Serial Port
and write down the name of the port (ex. COMS3) which is needed for avrdude.

Finally, press Files->Upload to load ArduinolSP to Arduino Uno. This operation transforms Arduino Uno
into an ISP programmer.

(2) Connect the ISP pins of Arduino Uno to the Target AVR as indicated in Fig.1
It is extremely important to make sure that the ISP pins of Arduino Uno are connected to the Target AVR
like this:

Arduino Uno Target AVR (ex. Atmega328p)

SS RESET
MOSI MOSI
MISO MISO
SCK SCK

Frequent wiring mistakes are Arduino Uno(SS) -> Target AVR(SS) and Arduino Uno(RESET) -> Target
AVR(RESET).

As a note: The crystal and its two capacitors have to be as close to XTAL1L, XTAL?2 pins of the Target AVR
as possible (like in Fig. 1). If you position them in a different configuration, far from the processor, running
wires between capacitors, crystal and the AVR, the newly formed oscillator can refuse to work and avrdude
will throw the error “Invalid device signature” when you try to program the microcontroller.

(3) Write your source code, compile it and generate the hex file
In Arduino 1.0.1->Files->Preferences check Show verbose output during compilation. This will display a
lot of information, when the code is compiled, including the location of the hex file.

Go to File->Examples->01.Basics and load Blink example. This will be considered as your source code.
Go to Sketch menu and press Verify/Compile.

When the compilation completes search in the lower side of the screen the path of the generated Blink hex
file. It looks like this one:

C:\Users\Victor\AppData\Local\Temp\build1325897986179133197.tmp\Blink.cpp.hex

Select it with the mouse and press Ctrl-C followed by a Paste in Notepad, for instance. You will need the
path for avrdude.

REMARK: The hex file can be generated with any IDE you like, not necessarily using Arduino 1.0.1. You
can write your code in: BASCOM, CodeVision, AVR Studio, IAR which, in most cases, are far better
choices than Arduino 1.0.1.

ATTENTION! If you use Arduino 1.0.1 to generate a hex file, you have to select the right board/processor
from Tools->Board. For example, you simply can not compile the Blink Led code for Arduino Uno



(Atmega328p) and expect it to work on a target Atmega32 microcontroller. Also, even if, your target chip
on the breadboard is an Atmega328p DIL28, you have to take into account that pin 13 of Arduino Uno (the
one that drives the led) corresponds to pin 19 (SCK) on your target Atmega328p microcontroller.

AS A CONCLUSION: Arduino 1.0.1 works well for compiling code written for the boards in its list.

For anything else, different boards or stand alone AVRs, it is highly indicated to use a general purpose
IDE, not Arduino 1.0.1.

(4) Use avrdude command lines to upload the hex file into the Target AVR
Avrdude comes bundled with WinAVR, a software that is free and can be found on the internet.

Locate avrdude inside WinAVR, start the Windows standard application Command Prompt and launch
avrdude from within Command Prompt.

A better choice would be to use a software, similar to Command Prompt but much easy to use, called
PowerCmd because it allows you to save and copy-paste the long avrdude command lines, with many
options and complicated paths to hex files, necessary to program an AVR (see the example).

At this moment, it is supposed that Arduino Uno is already loaded with ArduinolSP, connected to the PC
with an USB cable and all wires, between the Target AVR and Arduino Uno acting as an ISP programmer,
are in their place as in Fig. 1.

For the example that follows, the Target AVR is chosen to be an Atmega328p already set to run at 16 MHz.
EXAMPLE:

Launch PowerCmd (or Command Prompt) and copy this line:

c:\>avrdude -P COM3 -b 19200 -c avrisp -p m328p -n

in one of its command windows.

If your AVR is different then change the option -p m328p to -p ... corresponding to your microcontroller.
Most likely you do not have to modify the other options. (Note: The command c:\>avrdude -? will display a
list with explanations regarding the meaning of the switches: —P, -b, -c, -p, -n and many others.)

Press Enter.

Avrdude should display the message:

c:\>avrdude -P COM3 -b 19200 -c avrisp -p m328p -n
avrdude: AVR device initialized and ready to accept instructions
Reading | #######444444H4H4H4HF 4 FHHFHFHFHHHHHHRFHFHFHFHEHE | 1008 0.14s

avrdude: Device signature = 0x1e950f
avrdude: safemode: Fuses OK
avrdude done. Thank you.

telling you that the Target AVR is accessible and can be programmed. (-n option instructs avrdude to make
no modification inside the Target AVR).

You can program now the Target AVR with the Blink.cpp.hex file, generated at point (3), by copying the
avrdude command, highlighted in red (see below), in PowerCmd and pressing Enter.

Do not forget to change the path to the hex file (the string of characters between ) according to the settings
in your computer. The rest of the command line, including the final “:i” will likely remain unchanged.



c:\>avrdude -P COM3 -b 19200 -c avrisp -p m328p -u -U
flash:w:"C:\Users\Victor\AppData\Local\Temp\build1325897986179133197. tmp\Blink.
cpp.hex":i

avrdude: AVR device initialized and ready to accept instructions
Reading | #######4#444444H4H4H4H4HEHEHHHHHHHHHSHREREHEHE#E#E | 1005 0. 165

avrdude: Device signature = 0x1e950f

avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
To disable this feature, specify the -D option.

avrdude: erasing chip

avrdude: reading input file

"C:\Users\Victor\AppData\Local\Temp\build1325897986179133197.tmp\Blink.cpp.hex"

avrdude: writing flash (1084 bytes):

Writing | ####444HH#44FFEFSHAHAFESRSAHAFESSASHAFSSSSSHSAFEESS | 1005 1.76s

avrdude: 1084 bytes of flash written

avrdude: verifying flash memory against
C:\Users\Victor\AppData\Local\Temp\build1325897986179133197.tmp\Blink.cpp.hex:
avrdude: load data flash data from input file
C:\Users\Victor\AppData\Local\Temp\build1325897986179133197.tmp\Blink.cpp.hex:
avrdude: input file
C:\Users\Victor\AppData\Local\Temp\build1325897986179133197.tmp\Blink.cpp.hex contains
1084 bytes

avrdude: reading on-chip flash data:

Reading | ########4#HFHH#AHFHHHAFARFHFFAFFRFESAAFHSFASARFERHAS | 1005 1.31s

avrdude: verifying
avrdude: 1084 bytes of flash verified

avrdude done. Thank you.

Success! At this moment your Target AVR is programmed and ready to execute the code.

Most common errors you may get from avrdude:

1) c:\>»avrdude -P COM3 -b 19200 -c avrisp -p m328p -n
avrdude: ser open(): can't open device "\\.\COM3": The system cannot find the file
specified.

Reason: The USB connection between the PC and Arduino Uno is not good. If the connection is good but
the error still keeps coming press the Reset button of Arduino Uno.

2) c:\>»avrdude -P COM3 -b 19200 -c avrisp -p m328p -n
avrdude: ser open(): can't open device "\\.\COM3": Access 1is denied.

Reason: Another application that uses COM3 port, likely a Serial Monitor, is running. Close it.

3) c:\>c:\>avrdude -P COM3 -b 19200 -c avrisp -p m328p -n
Access is denied.

Reason: ¢ drive appears twice: “c:\>c:\>”.



4) c:\>avrdude -P COM3 -b 19200 -c avrisp -p m328p -n

avrdude: stk500 program enable():

avrdude: initialization failed,

this check.

protocol error,
rc=-1
Double check connections and try again,

expect=0x14,

avrdude: stk500 disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

Reason: The Target AVR is not powered or does not exist.
This message is also useful for testing, before connecting any Target AVR, that Arduino Uno +

ArduinolSP work as an ISP programmer and the connection to the PC is proper.

5) c:\>avrdude -P COM3 -b 19200 -c avrisp -p m328p -n
avrdude: stk500 getsync(): not in sync: resp=0xf0

avrdude done. Thank you.

Reason: Arduino Uno needs a Reset.

6) c:\>»avrdude -P COM3 -b 19200 -c avrisp -p m328p -n
avrdude: AVR device initialized and ready to accept instructions
Reading | #########4#4#4H#H#HFHHHHHHHHFHFAHAHAHHFHFHHHHSHSHRA
oxffffff (Device signature = 0x000000)
avrdude: Yikes! 1Invalid device signature.

avrdude: Device signature =

Double check connections and try again,

this check.

Reasons:

100%

resp=0x50

or use -F to override

0.14s

or use -F to override

a) ISP connections (SS, MOSI, MISO, SCK) -> (RESET, MOSI, MISO, SCK), between Arduino
Uno and the Target AVR, are not good, wrong wiring.
b) The AVR oscillator (external) does not work.

List of commonly used AVRs and how they should be connected to an Arduino

Uno, for programming

If you do not use an Atmega328p target then you should adapt the wiring in Fig. 1 according to your specific
target AVR (ex. Attiny13, 84, 85, Atmega8, etc.).

Attiny13

8-PDIP/SOIC

(PCINTS/RESET/ADCO/dW) PB5 [] 1
(PCINT3/CLKIVADC3) PB3 ] 2
(PCINT4/ADC2) PB4 [] 3

GND [ 4

W

8
7
6
5

1 VCC

1 PB2 (SCK/ADC1/TO/PCINT2)

1 PB1 (MISO/AINT/OCOB/INTO/PCINT1)
[ 1 PBO (MOSI/AINO/OCOA/PCINTO)

Uno -> pin Attiny13

SS->1
MQOSI ->5
MISO -> 6
SCK ->7



Attiny84
PDIP/SOIC
S
vCC 1 141 GND
(PCINT8/XTAL1/CLKI) PBO [} 2 13| PAD (ADCO/AREF/PCINTO)
(PCINT9/XTaL2) PB1 O 3 12 [ PA1 (ADC1/AINO/PCINT1)
(PCINT11/RESET/dW) PB3 (| 4 11 [ PA2 (ADG2/AIN1/PCINTZ2)
(PCINT10/INTO/OCOA/CKOUT) PB2 ] 5 10 [0 PA3 (ADC3/TO/PCINT3)
(PCINT7/ICP/OCOB/ADCT7) PA7 (| 6 91 PA4 (ADC4/USCK/SCL/T1/PCINT4)

(PCINT8/OC1A/SDA/MOSI/DI/ADCE) PA6 L] 7 81 PA5 (ADC5/DO/MISO/OC1B/PCINTS)

Attiny85

PDIP/SOIC/TSSOP
e

(PCINTS/RESET/ADCO/dW) PB5 [ 1
(PCINT3/XTAL1/CLKI/OCTB/ADC3) PR3 [] 2
(PCINT4/XTAL2/CLKO/OC1B/ADC2) PB4 [] 3
GND ] 4

Atmega8
PDIP
J
(RESET) PCB ] 1 28 [ PC5 (ADC5/SCL)
(RXD) PDOO 2 27 [0 PC4 (ADC4/SDA)
(TXD) PD1] 2 26 [1PC3 (ADC3)
{INTO) PD2 4 25 PC2 (ADC2)
(INT1) PD3]5 24 PC1 (ADC1)
(XCK/TO) PD4 8 23[] PCO (ADCO)
vece Q7 22 GND
GND L8 21 [J AREF
(XTAL1/TOSC1) PBE T @ 20[JAVCC
(XTAL2TOSC2) PB7 ] 10 19 [ PB5 (SCK)
(T1) PD5 [ 11 18 [1 PB4 (MISO)
(AINO) PDB (] 12 17 [1 PB3 (MOSI/OC2)
(AIN1) PD7 O] 12 16 [0 PB2 (SS/0C1B)
(ICP1) PBO ] 14 150 PB1 (OC1A)

a8 [vCC

7 [ PB2 (SCK/USCK/SCL/ADC1/TO/INTO/PCINT2)
6 [] PB1 (MISO/DO/AINT/OCOB/OCTI A/PCINTT)
5 [0 PBO (MOSI/DI/SDASAINO/OCOA/DTT A/AREF/PCINTO)

Atmega328p

Uno -> pin Attiny84

SS->4
MOSI->7
MISO -> 8
SCK->9

Uno -> pin Attiny85

SS->1
MOSI ->5
MISO ->6
SCK->7

(PCINT14/RESET) PC6 [
(PCINT16/RXD) PDO
(PCINT17/TXD) PD1
(PCINT18/INTO) PD2

(PCINT19/OC2B/INT 1) PD3
(PCINT20/XCK/TO) PD4 ]
VCC [

GND [
(PCINT&/XTALT/TOSC1) PBE O
(PCINTT/XTAL2TOSC2) PBT O
(PCINT21/0COB/T1) PD5 O
(PCINT22/0COA/AIND) PDE L
(PCINT23/AINT) PDT O
(PCINTD/CLKO/AICP1) PBOC

12
13
14

28
27
26
25
24
23
22
21
20
19
18
17
16
15

1 PCS (ADCS/SCL/PCINT13)
[1PC4 (ADCA/SDA/PCINT12)
1 PC3 (ADC3/PCINT11)

1 PC2 (ADCZ/PCINT10)
[1PC1 (ADC1/PCINTS)

1 PCO (ADCO/PCINTS)

1 GND

1 AREF

K AVCC

1 PB5 (SCKIPCINTS)

1 PB4 (MISO/PCINT4)

1 PB3 (MOSIOCZA/PCINTI)
1 PB2 (S5/0C1B/PCINT2)

1 PB1(OC1APCINTI)

(Arduino Uno -> pin Atmega8, Atmega328p) — (SS -> 1, MOSI -> 17, MISO -> 18, SCK -> 19)



Uno>Atmega32U4

Atmega32U4
w oo g =
EEEE SS->13
S = & uL_‘J E [
oo § W o MOSI -> 10
Qa2 ., MISO -> 11
zszEfEEfEEEES SCK ->9
(INTeaIND) PES  [1] Q.¥ [33] PE2(HWE)
e 23] PCT (ICPUCLKO/OCSA)
. INDEX CORMNER & -
D- [31] PCE (0C3AOC4A)
D+ [30] PB6 (PCINTE/OC1BIOC4B/ADCT3)
uend 28] P85 (PCINTS/IOCIACCARADG1Z)
ucap [6] ATmega32u4 (28] PB4 (PCINT&ADC11)
ATmegal&l4 =7 PO7
vBus [7 TOADCADVADC10)
- 44-pin QFNITQFP B
(SS/PCINTO) PED |26] PDS (T1/0C4D/ADCY)
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(PDIPCINTZIMOS!) PE2 24] AvCG
[PDO/PCINTI/MISO) PE3 23] GnD
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Atmega32 Uno -> pin Atmega32

PDIP
J SS->9
(XCKITO) PBO O 1 40 b1 PA0 (aDcoy ~ MOSI->6
(T1) PB1 ] 2 39 b pa1 (aDc)  MISO->7
(INTZ/AINO) PB2 O 3 38 b pa2 (aDc2y SCK->38
(OCO/AINT) PB3 ] 4 37 [0 PA3 (ADC3)
(52) PB4 O 5 36 [0 PA4 (ADC4)
(MOSI) PB5 O 6 35 [0 PAS (ADCS)
(MISQ) PB6 ] 7 34 [ PAB (ADCS)
(SCK) PB7 O] & 33 [0 PA7 (ADCT)
RESET O 9 32 O AREF
vee O 10 31 0 GND
GND o 11 30 O AVCC
XTAL2 O 12 29 [ PCT7 (TOSC2)
XTAL1 O 13 28 B PC6 (TOSC1)
(RXD) PDO O 14 27 B PCs (TDI)
(TXD) PD1 ] 15 26 b PC4 (TDO)
(INTO) PD2 O 18 25 1 PC3 (TMS)
(INT1) PD3 ] 17 24 B PC2 (TCK)
(OC1B) PD4 ] 18 23 O PC1 (SDA)
(OC1A) PD5 ] 19 22 0 PCO (SCL)
(IcP1) PD6 ] 20 21 [ PD7 (OC2)




